1. Уважаемые гости и новички, приветствуем Вас на нашем форуме
    Здесь вы можете найти ответы практически на все свои вопросы о серии игр «Готика» (в том числе различных модах на нее), «Ведьмак», «Ризен», «Древние свитки», «Эра дракона» и о многих других играх. Можете также узнать свежие новости о разработке новых проектов, сыграть в увлекательные ФРПГ, восхититься творчеством наших форумчан, либо самим показать, что вы умеете. Ну и наконец, можете обсудить общие увлечения или просто весело пообщаться с посетителями «Таверны».

    Чтобы получить возможность писать на форуме, оставьте сообщение в этой теме.
    Удачи!
    Скрыть объявление
  2. Форум аддона "Возвращение" 2.0:
    — Обсудить игру, почитать о прохождениях и/или разрешить свои вопросы по игре вы можете в одной из тем одноименного форума. Посетить...
    — Прочитать историю изменения и/или скачать последнюю версию аддона "Возвращение", вы можете на страницах наших ресурсов. Скачать...
    Скрыть объявление

Возвращение 2: AST.DLL not loaded problem

Тема в разделе "Возвращение, версия: 2.0", создана пользователем Mayhem91, 11 дек 2017.

Модераторы: Ku6oPr
  1. Mayhem91

    Mayhem91 Участник форума

    Регистрация:
    11 дек 2017
    Сообщения:
    31
    Благодарности:
    0
    Баллы:
    10
    Hi everyone am from Poland so very sorry if this topic is in wrong side becouse I dont understand russian languague.

    My problem is begin after I installed Returning 2.0 V0066R1 and while I try to start a new game game shoot down and I have Access Violation becoufe of "AST.DLL not loaded". This message is show with window similar to CMD.exe during starting gothic2.exe. I have this file from Hotfix7 but game dont see them I dont know why.

    Before I had other problem with missing MVSCP140.DLL and VCRUNTIME140.DLL but I download this both from google (64-bit version) and this error gone away but still game dont see AST.DLL.

    Please help me I want to play this. Before I format the computer was good and I can played but now dont. Returning 1.1 in other path works good only 2.0 have problem because of AST.DLL problem
     
  2. STARK

    STARK Участник форума

    Регистрация:
    20 янв 2011
    Сообщения:
    352
    Благодарности:
    81
    Баллы:
    190
    Пол:
    Мужской
    Try to install up-to-date version from here: http://worldofplayers.ru/threads/39914/
    -> http://worldofplayers.ru/resources/84/download?version=264
    On clean G2NR.
    About dll's, it would be batter if you'll install vc libs, both x32 & x64, instead of downloading single dll's.
    Put it in the game folder is not such a good solution.
    By the way, mod's installation has required vc libs. So I advise you to install all required software from installation menu first, then install the mod.
    What Windows are you using?
     
    Последнее редактирование: 11 дек 2017
  3. Mayhem91

    Mayhem91 Участник форума

    Регистрация:
    11 дек 2017
    Сообщения:
    31
    Благодарности:
    0
    Баллы:
    10
    Windows 7 - 64-bit I have Visual C++ 2010-2013 x86 and x64. I must play on V0066R1 becouse of Polish Autotranslate are not available on other version. Before format I played too on this version and works good. I installed Returning yet 3-4 times and I still cant play. I have the newest Hotfix7 fot this version which included AST.DLL
     
  4. STARK

    STARK Участник форума

    Регистрация:
    20 янв 2011
    Сообщения:
    352
    Благодарности:
    81
    Баллы:
    190
    Пол:
    Мужской
    If you use some special version, maybe you should ask about your problem in a place where you got it?
    There you'll have more chances that someone will help you.
     
    Последнее редактирование: 11 дек 2017
    Mayhem91 поблагодарил.
  5. Mayhem91

    Mayhem91 Участник форума

    Регистрация:
    11 дек 2017
    Сообщения:
    31
    Благодарности:
    0
    Баллы:
    10
    Am asking on polish board but no one know how to help me or they dont treat me seriously. I install now the newest version Visual C++ but problem still alive.

    P.S: I can install V0062 and english version but you really think that this something change for me with this problems ?


    Where I can download english translate for V0066R2 ??
     
    Последнее редактирование: 11 дек 2017
  6. STARK

    STARK Участник форума

    Регистрация:
    20 янв 2011
    Сообщения:
    352
    Благодарности:
    81
    Баллы:
    190
    Пол:
    Мужской
    I am not shoore:)
    By the link I provide earlier. Seems it has endlish and german localizations, but I don't test it by myself:)
    Give me the link to your version. Did you follow all of the instructions from there?
    Maybe hotfix you are using is for another version?
     
    Последнее редактирование: 11 дек 2017
    Mayhem91 поблагодарил.
  7. Mayhem91

    Mayhem91 Участник форума

    Регистрация:
    11 дек 2017
    Сообщения:
    31
    Благодарности:
    0
    Баллы:
    10
    No am doing everything good I always check everything especially version's etc. I install V066R2 in different location but problem is the same like before still
    "AST.DLL not loaded" and I cant load new game in main menu. Before i trying too install without any hotfix after with hotifix so I tried many combination but result equals the same. It's stupid because when I install this first time I dont had AST problem of course new game was not loaded as now but AST problem was not appear. Now result is the same but because of this file problem.
     
  8. STARK

    STARK Участник форума

    Регистрация:
    20 янв 2011
    Сообщения:
    352
    Благодарности:
    81
    Баллы:
    190
    Пол:
    Мужской
    Show me where you got your version.
     
  9. Mayhem91

    Mayhem91 Участник форума

    Регистрация:
    11 дек 2017
    Сообщения:
    31
    Благодарности:
    0
    Баллы:
    10
  10. STARK

    STARK Участник форума

    Регистрация:
    20 янв 2011
    Сообщения:
    352
    Благодарности:
    81
    Баллы:
    190
    Пол:
    Мужской
    Did you try to start the game without Hotfix 7 (Google-polish-patch)?
    Did you install gothic2_fix-2.6.0.0-rev2, gothic2_playerkit-2.6f, SystemPack 1.7?
    Maybe it's not necessary, as mod instalation probably do it. But you could try install it by yourself.
     
  11. Mayhem91

    Mayhem91 Участник форума

    Регистрация:
    11 дек 2017
    Сообщения:
    31
    Благодарности:
    0
    Баллы:
    10
    1. Yes I try I told this up ^.
    2. Yes but without SystemPack 1.7 (i dont remember which version I have can you give me link ?)
     
  12. Ku6oPr

    Ku6oPr ★★★★★★★
    Модератор

    Регистрация:
    21 июл 2009
    Сообщения:
    1.015
    Благодарности:
    256
    Баллы:
    295
    Пол:
    Мужской
    for last bild all required before 2017 for x86 and x64 system.
     
  13. STARK

    STARK Участник форума

    Регистрация:
    20 янв 2011
    Сообщения:
    352
    Благодарности:
    81
    Баллы:
    190
    Пол:
    Мужской
    http://dl1.worldofplayers.ru/games/gothic/patches/systempack/g2returning-systempack-1.6.exe
    https://yadi.sk/d/vuWbU8nQ3G8ZFW

    Try this AST: https://drive.google.com/open?id=1RRIJmmh3gjisq6qbAf3ETqN2h-drnDWN
    It's from 66 version. Place it to G2 system folder.

    If this doesn't work, try to install newest version of the mod (link in my first message). I even try it now, it works fine. If an error continue to appear, then problem is in your Gothic (original game).
    In that case, find another one.

    But most likely, this error appears becouse of incompatible ast build.
     
    Последнее редактирование: 11 дек 2017
  14. Mayhem91

    Mayhem91 Участник форума

    Регистрация:
    11 дек 2017
    Сообщения:
    31
    Благодарности:
    0
    Баллы:
    10
    I cant install g2returning systempack 1.7 because when I set my path I dont have available "Install" button. Maybe I have this because I see in my path g2NOTR systempack unistall file.

    This new AST files remove my problem with "AST.DLL not loaded" but game still dont finish loading and Access Violation appear. Maybe I doing somthing wrong because when i click on AgamaST.exe i have error "Create process: Error! Invalid Gothic2.exe" but AST.DLL works good I copy both files from "Release" folder to Gothic system.
     
  15. STARK

    STARK Участник форума

    Регистрация:
    20 янв 2011
    Сообщения:
    352
    Благодарности:
    81
    Баллы:
    190
    Пол:
    Мужской
    Try 1.6, but uninstall preveus first.

    I uploaded another ast file, try this one: https://drive.google.com/open?id=1RRIJmmh3gjisq6qbAf3ETqN2h-drnDWN
    Start game only with Gothic2.exe.
     
  16. Ku6oPr

    Ku6oPr ★★★★★★★
    Модератор

    Регистрация:
    21 июл 2009
    Сообщения:
    1.015
    Благодарности:
    256
    Баллы:
    295
    Пол:
    Мужской
    This sending on your install game is not original disk. Your file Gothic2.exe does not fit for intall G2V2.0. I install game only on russian language, perhaps for other language, true other requirements.
    Gouing http://worldofplayers.ru/resources/38/ and reading topic.
     
  17. Mayhem91

    Mayhem91 Участник форума

    Регистрация:
    11 дек 2017
    Сообщения:
    31
    Благодарности:
    0
    Баллы:
    10
    This AST are not loaded like before so I keep this which work. I cant install systempack 1.6 too even if before I unistall g2NOTR systempack strange. I tommorow try to change game path and maybe this will be good for install this
     
  18. Ku6oPr

    Ku6oPr ★★★★★★★
    Модератор

    Регистрация:
    21 июл 2009
    Сообщения:
    1.015
    Благодарности:
    256
    Баллы:
    295
    Пол:
    Мужской
    adding file Gothic2.exe expulsion for DEP in system parametrs
     
  19. Gratt

    Gratt
    Модостроитель

    Регистрация:
    14 ноя 2014
    Сообщения:
    984
    Благодарности:
    1.051
    Баллы:
    175
    Пол:
    Мужской
    Don't touch original systempack! In returning 2.0 it connects AST to process. If in cmd sp write "AST.dll not loaded" - u don't have AST. And check full Gothic path for special symbols.

    Dep only for ikarus.

    U need clear Gothic 2.6, systempack and AST from r2.0 installer and gothic2.exe report version.
     
  20. STARK

    STARK Участник форума

    Регистрация:
    20 янв 2011
    Сообщения:
    352
    Благодарности:
    81
    Баллы:
    190
    Пол:
    Мужской
    Can't touch this!:D
     
Модераторы: Ku6oPr

Поделиться этой страницей